summaryrefslogtreecommitdiff
path: root/deadbeef/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'deadbeef/PKGBUILD')
-rw-r--r--deadbeef/PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/deadbeef/PKGBUILD b/deadbeef/PKGBUILD
new file mode 100644
index 0000000..28a579b
--- /dev/null
+++ b/deadbeef/PKGBUILD
@@ -0,0 +1,55 @@
+# Contributor: Alexey Yakovenko <waker@users.sourceforge.net>
+
+pkgname=deadbeef
+pkgver=1.8.8
+pkgrel=1
+pkgdesc='A GTK+ audio player for GNU/Linux.'
+arch=('x86_64')
+url='http://deadbeef.sourceforge.net'
+license=('GPL2')
+depends=('alsa-lib' 'hicolor-icon-theme' 'desktop-file-utils' 'jansson')
+makedepends=('libvorbis' 'libmad' 'flac' 'curl' 'imlib2' 'wavpack' 'libsndfile' 'libcdio' 'libcddb'
+ 'libx11' 'faad2' 'zlib' 'intltool' 'pkgconfig' 'libpulse' 'libzip' 'libsamplerate' 'libdispatch'
+ 'yasm' 'ffmpeg' 'gtk2' 'gtk3')
+optdepends=('gtk2: for the GTK2 interface'
+ 'gtk3: for the GTK3 interface'
+ 'libsamplerate: for Resampler plugin'
+ 'libvorbis: for Ogg Vorbis playback'
+ 'libmad: for MP1/MP2/MP3 playback'
+ 'mpg123: for MP1/MP2/MP3 playback'
+ 'flac: for FLAC playback'
+ 'curl: for Last.fm scrobbler, SHOUTcast, Icecast, Podcast support'
+ 'imlib2: for artwork plugin'
+ 'wavpack: for WavPack playback'
+ 'libsndfile: for Wave playback'
+ 'libcdio: audio cd plugin'
+ 'libcddb: audio cd plugin'
+ 'faad2: for AAC/MP4 support'
+ 'dbus: for OSD notifications support'
+ 'pulseaudio: for PulseAudio output plugin'
+ 'libx11: for global hotkeys plugin'
+ 'zlib: for Audio Overload plugin'
+ 'libzip: for vfs_zip plugin'
+ 'ffmpeg: for ffmpeg plugin'
+ 'libdispatch: for last.fm plugin')
+
+source=("https://sourceforge.net/projects/deadbeef/files/travis/linux/${pkgver}/deadbeef-${pkgver}.tar.bz2")
+sha512sums=('399f0e70eca5e102a9e73ff03199c89c6f28f3e0da96e793316d1af83f00e71f09f6cc81a3fd0b0f0d52fe9e0195a3b9ffb0cf7e7708c3ea7085f33a5ec08b47')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export CC=/usr/bin/clang
+ export CXX=/usr/bin/clang++
+ ./configure --prefix=/usr
+}
+
+build () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}