summaryrefslogtreecommitdiff
path: root/fcp-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'fcp-git/PKGBUILD')
-rw-r--r--fcp-git/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/fcp-git/PKGBUILD b/fcp-git/PKGBUILD
new file mode 100644
index 0000000..09ffc1d
--- /dev/null
+++ b/fcp-git/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Deposite Pirate <dpirate at metalpunks dot info>
+#
+# Upstream: https://git.metalpunks.info/arch-ports
+
+_pkgname=fcp
+pkgname=fcp-git
+pkgver=v0.1.0.r0.ga1e61f7
+pkgrel=1
+pkgdesc="A faster rust cp command"
+arch=('i686' 'x86_64')
+url="https://github.com/Svetlitski/fcp"
+license=('BSD')
+depends=('glibc' )
+makedepends=('git' 'rust' 'cargo')
+source=("${_pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "${_pkgname}"
+ cargo install --no-track --locked --all-features --path . \
+ --root "${pkgdir}/usr/"
+ install -Dm 644 LICENSE README.md -t "${pkgdir}/usr/share/doc/fcp"
+}