summaryrefslogtreecommitdiff
path: root/parzip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'parzip/PKGBUILD')
-rw-r--r--parzip/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/parzip/PKGBUILD b/parzip/PKGBUILD
new file mode 100644
index 0000000..dc66947
--- /dev/null
+++ b/parzip/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Deposite Pirate <dpirate at metalpunks dot info>
+#
+# Previous maintainers:
+# Johannes Maibaum <jmaibaum at gmail dot com>
+#
+# Upstream: https://git.metalpunks.info/arch-ports
+
+pkgname=parzip
+pkgver=1.3.0
+pkgrel=2
+pkgdesc="A command line utility to pack and unpack zip archives using multiple threads."
+license=('GPL3')
+arch=('x86_64')
+depends=('xz' 'zlib')
+makedepends=('meson')
+url="https://github.com/jpakkane/parzip"
+source=("https://github.com/jpakkane/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.zip")
+sha256sums=('2497305ce36d3b6225d9517fa5d4c408adef3935f5f736174e218f971caeb7bb')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ meson --prefix=/usr build
+ ninja -C build
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ninja -C build test
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ DESTDIR="$pkgdir" meson install -C build
+}