summaryrefslogtreecommitdiff
path: root/comic-neue/PKGBUILD
diff options
context:
space:
mode:
authorDeposite Pirate2022-02-08 02:19:44 +0100
committerDeposite Pirate2022-02-08 02:19:44 +0100
commit2cf17b7e6f80e0d8dc322e06c32dde26898f1fa5 (patch)
tree130d0bbb92aebb1818e0c3410276eae78c855c8e /comic-neue/PKGBUILD
parent23d9572654253014344f296a99f6dd68008197ac (diff)
A replacement for Comic Sans MS
new file: comic-neue/.SRCINFO new file: comic-neue/PKGBUILD new file: comic-neue/fontconfig.conf
Diffstat (limited to 'comic-neue/PKGBUILD')
-rw-r--r--comic-neue/PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/comic-neue/PKGBUILD b/comic-neue/PKGBUILD
new file mode 100644
index 0000000..856ea40
--- /dev/null
+++ b/comic-neue/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Deposite Pirate <dpirate at metalpunks dot info>
+#
+# Upstream: https://git.metalpunks.info/arch-ports
+
+pkgbase=comic-neue
+pkgname=(ttf-comic-neue otf-comic-neue)
+pkgver=2.51
+pkgrel=1
+pkgdesc='Comic Neue is an extended replacement for the Comic Sans MS font'
+arch=('any')
+url='http://comicneue.com'
+license=('custom:OFL')
+source=("${url}/${pkgbase}-${pkgver}.zip"
+ 'fontconfig.conf')
+sha256sums=('54dd998c93b8d6658b1c2d6ade9f790d10ffaa3632868dd2cfac84b405290321'
+ 'c30876b732eaf4b6491642a53651b31259ba36308c4e668b1e37ad2c8ad86088')
+
+function _package {
+
+ cd "${pkgbase}-${pkgver}"
+
+ case "${1}" in
+ ttf-comic-neue)
+ pkgdesc='Comic Neue is an extended replacement for the Comic Sans MS font'
+ cd TTF
+ fonts=(ComicNeue/*.ttf ComicNeue-Angular/*.ttf)
+ installdir=TTF;;
+ otf-comic-neue)
+ pkgdesc='Comic Neue is an extended replacement for the Comic Sans MS font'
+ cd OTF
+ fonts=(ComicNeue/*.otf ComicNeue-Angular/*.otf)
+ installdir=OTF;;
+ esac
+
+ install -dm755 "${pkgdir}/usr/share/fonts/${installdir}"
+
+ for font in "${fonts[@]}"; do
+ install -m644 "${font}" "${pkgdir}/usr/share/fonts/${installdir}"
+ done
+
+ install -D -m644 ../../fontconfig.conf \
+ "${pkgdir}/usr/share/fontconfig/conf.avail/75-${pkgname}.conf"
+
+ install -D -m644 ../OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
+
+for _pkgname in ${pkgname[@]}; do
+ eval "function package_${_pkgname}() { _package ${_pkgname}; }"
+done