summaryrefslogtreecommitdiff
path: root/hexchat-otr-git/PKGBUILD
diff options
context:
space:
mode:
authorDeposite Pirate2019-05-30 19:39:15 +0200
committerDeposite Pirate2019-05-30 19:39:15 +0200
commit9bd48a79729bb8f640314610a67bfb2499661d47 (patch)
treebf7943fe3c2c2ac48fd58f2f531eb58a5af65348 /hexchat-otr-git/PKGBUILD
parent82f7a6824d04bfd69a2cf678c7f3d2ab213e3cb1 (diff)
* Update build to use meson.
modified: .SRCINFO modified: PKGBUILD
Diffstat (limited to 'hexchat-otr-git/PKGBUILD')
-rw-r--r--hexchat-otr-git/PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/hexchat-otr-git/PKGBUILD b/hexchat-otr-git/PKGBUILD
index ef87165..fed385c 100644
--- a/hexchat-otr-git/PKGBUILD
+++ b/hexchat-otr-git/PKGBUILD
@@ -3,18 +3,18 @@
# Upstream: https://git.metalpunks.info/arch-ports
pkgname=hexchat-otr-git
-pkgver=r50.ga7a6016
-pkgrel=2
+pkgver=r52.g22d5495
+pkgrel=1
pkgdesc="OTR support for hexchat"
url="https://github.com/TingPing/hexchat-otr"
license=('GPL2')
arch=('i686' 'x86_64')
depends=('hexchat' 'libotr>=4.1.0')
-makedepends=('git' 'gnome-common')
+makedepends=('git' 'meson')
conflicts=('hexchat-otr')
provides=('hexchat-otr')
source=("${pkgname}::git+${url}")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
@@ -25,12 +25,11 @@ pkgver() {
build() {
cd "${pkgname}"
- ./autogen.sh
- CFLAGS="${CFLAGS}" ./configure --prefix="/usr"
- make
+ arch-meson build -D local_install=false
+ ninja -C build
}
package() {
cd "${pkgname}"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
}