summaryrefslogtreecommitdiff
path: root/hexchat-otr-git/PKGBUILD
diff options
context:
space:
mode:
authorDeposite Pirate2018-09-17 11:15:55 +0200
committerDeposite Pirate2018-09-17 11:15:55 +0200
commitdf4b04ba1fdcc9b5fb3c7ec28c42820df1ec5ca7 (patch)
tree898173097e70af73ccbce58111ebefbc26496cae /hexchat-otr-git/PKGBUILD
parent0ad5ef6dad01452b820384473d68ca09ac5e8024 (diff)
Add hexchat-otr-git.
Diffstat (limited to 'hexchat-otr-git/PKGBUILD')
-rw-r--r--hexchat-otr-git/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/hexchat-otr-git/PKGBUILD b/hexchat-otr-git/PKGBUILD
new file mode 100644
index 0000000..393c3df
--- /dev/null
+++ b/hexchat-otr-git/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Deposite Pirate <dpirate at metalpunks dot info>
+
+pkgname=hexchat-otr-git
+pkgver=r50.ga7a6016
+pkgrel=2
+pkgdesc="OTR support for hexchat"
+url="https://github.com/TingPing/hexchat-otr"
+license=('GPL2')
+arch=('i686' 'x86_64')
+depends=('hexchat' 'libotr>=4.1.0')
+makedepends=('git' 'gnome-common')
+conflicts=('hexchat-otr')
+provides=('hexchat-otr')
+source=("${pkgname}::git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.g%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+ ./autogen.sh
+ CFLAGS="${CFLAGS}" ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}