summaryrefslogtreecommitdiff
path: root/libgnt-hg/PKGBUILD
diff options
context:
space:
mode:
authorDeposite Pirate2018-12-27 04:08:37 +0100
committerDeposite Pirate2018-12-27 04:08:37 +0100
commite6e0f49b13594235d232e61aee11c4721c2b8981 (patch)
tree8cc89ed2d6cf64652fa2da504fe86a92659e73e6 /libgnt-hg/PKGBUILD
parent4c1441181a774019e52d728a10344183f3dd59ef (diff)
Add libgnt-hg.
new file: libgnt-hg/.gitignore new file: libgnt-hg/PKGBUILD
Diffstat (limited to 'libgnt-hg/PKGBUILD')
-rw-r--r--libgnt-hg/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/libgnt-hg/PKGBUILD b/libgnt-hg/PKGBUILD
new file mode 100644
index 0000000..81b929b
--- /dev/null
+++ b/libgnt-hg/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Deposite Pirate <dpirate at metalpunks dot info>
+#
+# Upstream: https://git.metalpunks.info/arch-ports
+
+_pkgname=libgnt
+pkgname=$_pkgname-hg
+pkgver=r1075.99ad336bd8bf
+pkgrel=1
+pkgdesc="ncurses widgets for Pidgin"
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/pidgin/libgnt"
+license=('GPL2')
+depends=('ncurses>=6.1' 'glib2>=2.58.0' 'icu>=63.1' 'libxml2>=2.9.8' 'python>=3.7.0')
+makedepends=('mercurial' 'meson' 'gtk-doc')
+source=("$pkgname::hg+https://bitbucket.org/pidgin/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" \
+ "$(hg identify -n)" \
+ "$(hg identify -i)"
+}
+
+build() {
+ cd "${pkgname}"
+ arch-meson build -Dtests=false
+ ninja -C build
+}
+
+package() {
+ cd "${pkgname}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}