aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDeposite Pirate2018-09-16 22:54:11 +0200
committerDeposite Pirate2018-09-16 22:54:11 +0200
commit1c7d481d0104add72933c560d957a422e8636d84 (patch)
tree2ef71132559dd018c453f4617d92ce69394e42f0 /configure.ac
Initial commit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..827bed7
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,24 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT
+AC_CONFIG_SRCDIR(gen.c)
+
+dnl Checks for programs.
+AC_SET_MAKE
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_INSTALL
+AC_PROG_LN_S
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(errno.h fcntl.h strings.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_FUNCS(strerror)
+
+dnl Checks for library functions.
+
+AC_CONFIG_FILES(Makefile)
+AC_OUTPUT